ASP.NET 4.0 Hosting Guide

.NET Framework 4 is required to run and develop ASP.NET 4.0 sites.

Install .NET Framework 4

The Microsoft .NET Framework 4 web installer package downloads and installs the .NET Framework. You could download it here.

Installation Requirements

Recommended Minimum: Pentium 1 GHz or higher with 512 MB RAM or more
Minimum disk space: 850 MB
Internet Information Services (IIS) version 6.0 or . . . → Read More: ASP.NET 4.0 Hosting Guide

Web Hosting Tutorials